1. Problem
  2. Solution

I had an issue with install R on Ubuntu 16.04. Message was about some inability to install a dependency of the main R package.

Problem

r-base : Depends: r-recommended (= 3.5.1-1build1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Solution

I needed to fix some broken packages? What solved it for me:

sudo apt --fix-broken install
sudo apt autoremove
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install r-base-dev